Author Topic: 500 internal server error after clean install 1.51.0  (Read 3145 times)

jasondansie

  • Tulokas
  • *
  • Posts: 3
I did a clean install of 1.51.0 on my server put in the credentials for the mysql server and all I get is a 500 internal server error. Any ideas what could be wrong. I looked in my log files and found nothing, also used the browser console to see if any error were there and I did not find anything. my site is www.goodcall.fi/mlinvoice15
Would be great if I could figure it out as now my older setup now does the same thing on the same server. which is www.goodcall.fi/mlinvoice
I did however get this to work with xampp on windows with my database so I do not know what is wrong.

Jason

Ere Maijala

  • Ylläpitäjä
  • *****
  • Posts: 940
Re: 500 internal server error after clean install 1.51.0
« Reply #1 on: 28.06.17 - klo:22:07 »
Without error logs things are usually difficult, but in this case it seems the problem is not in MLInvoice but something in the web server, since e.g. http://www.goodcall.fi/mlinvoice/gpl.txt, which should always be accessible, cannot be retrieved either.

--Ere

jasondansie

  • Tulokas
  • *
  • Posts: 3
Re: 500 internal server error after clean install 1.51.0
« Reply #2 on: 01.07.17 - klo:13:43 »
So I found the reason for this. It was file and folder permissions, they were all marked write for group. I just logged in with filezilla and changed the file permissions on folders to 755 and for files to 644.

Ere Maijala

  • Ylläpitäjä
  • *****
  • Posts: 940
Re: 500 internal server error after clean install 1.51.0
« Reply #3 on: 02.07.17 - klo:22:05 »
Good to hear, and thanks for the followup!