Composer detected issues?

Started by veskuh, 01.06.22 - klo:17:56

Previous topic - Next topic

veskuh

Yritin päivittää versioon 2.0.3, mutta kirjautumissivu näyttää vain tämän:
Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.3.0".

PHP pitäisi kyllä olla 7.4. Mitähän minä nyt en huomaa?

Edit: Apachen moduuli oli jäänyt versioon 7.2. Vaihdoin 7.4:ään ja nyt ikkuna jää valkoiseksi sekä uudella että vanhalla versiolla.

2.0.3 tulostaa html-error.logiin:
[php7:error] [pid 71823] [client 192.168.5.27:57213] PHP Fatal error:  Uncaught Error: Call to undefined function mysqli_connect() in /var/www/html/mlinvoice/sqlfuncs.php:43\nStack trace:\n#0 /var/www/html/mlinvoice/index.php(59): initDbConnection()\n#1 {main}\n  thrown in /var/www/html/mlinvoice/sqlfuncs.php on line 43

ja 1.23.1:
[php7:error] [pid 72091] [client 192.168.5.27:58081] PHP Fatal error:  Uncaught Error: Call to undefined function mysqli_connect() in /var/www/html/xxx/mlinvoice/sqlfuncs.php:43\nStack trace:\n#0 /var/www/html/xxx/mlinvoice/sqlfuncs.php(2303): initDbConnection()\n#1 /var/www/html/xxx/mlinvoice/sessionfuncs.php(30): require_once('/var/www/html/t...')\n#2 /var/www/html/xxx/mlinvoice/login.php(41): require_once('/var/www/html/t...')\n#3 {main}\n  thrown in /var/www/html/xxx/mlinvoice/sqlfuncs.php on line 43